CVE-2023-50783

Apache Airflow: Improper access control vulnerability on the "varimport" endpoint

MEDIUM 6.5

En bref

Source
NVD
EPSS
EPSS 1.39 % · centile 72 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
apache
Statut NVD
Modified

Description

Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue

Faiblesses (CWE)

  • CWE-284 — Contrôle d'accès incorrect

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 6.5CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NNVD · nvd@nist.gov (Primary)

Avis

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Apache Software Foundation · Apache Airflowaffected 0 < 2.8.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD