CVE-2024-21674

At a glance

Severity
HIGH 8.6
EPSS
EPSS 1.77 % · percentile 78 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
atlassian
NVD status
Modified

Description

This High severity Remote Code Execution (RCE) vulnerability was introduced in version 7.13.0 of Confluence Data Center and Server. Remote Code Execution (RCE) vulnerability, with a CVSS Score of 8.6 and a CVSS Vector of CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N allows an unauthenticated attacker to expose assets in your environment susceptible to exploitation which has high impact to confidentiality, no impact to integrity, no impact to availability, and does not require user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release 7.19.18, or any higher 7.19.x release * Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release * Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html ). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives ).

Scores

VersionScoreVectorScored by
CVSS 3.0HIGH 8.6CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:Natlassian
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NNVD · nvd@nist.gov (Primary)
CVSS 3.0HIGH 8.6CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:NNVD · security@atlassian.com (Secondary)

Weaknesses (CWE)

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Atlassian · Confluence Data Centerunaffected < 7.19.0 ; affected >= 7.19.0 ; affected >= 8.0.0 ; affected >= 8.1.0 ; affected >= 8.2.0 ; affected >= 8.3.0
Atlassian · Confluence Serverunaffected < 7.19.0 ; affected >= 7.19.0 ; affected >= 8.0.0 ; affected >= 8.1.0 ; affected >= 8.2.0 ; affected >= 8.3.0

References

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD