Apache Airflow: Dag Code and Import Error Permissions Ignored (Apache Software Foundation Apache Airflow)

CVE-2024-27906
MEDIUM 5.9

En bref

Source
NVD
EPSS
EPSS 0.34 % · centile 28 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
apache
Statut NVD
Modified

Description

Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI. Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability

Faiblesses (CWE)

  • CWE-862 — Autorisation absente

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 5.9CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LCISA-ADP
CVSS 3.1MEDIUM 5.9CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Avis

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Apache Software Foundation · Apache Airflowaffected 0 < 2.8.2

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD