CVE-2024-38473
Apache HTTP Server proxy encoding problem
HIGH 8.1
At a glance
- Source
- NVD
- EPSS
- EPSS 25.88 % · percentile 98 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Analyzed
Description
Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Weaknesses (CWE)
- CWE-116 — Improper Encoding or Escaping of Output
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H | CISA-ADP |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
European references
- ENISA EUVD · EUVD-2024-37354
- GCVE · GCVE-0-2024-38473
CERT-FR advisories
- CERTFR-2024-AVI-0750 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0676 — Multiples vulnérabilités dans Tenable Security Center · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0533 — Multiples vulnérabilités dans Apache HTTP Server · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*≥ 2.4.0 < 2.4.60cpe:2.3:a:netapp:ontap:9:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache HTTP Server | affected 2.4.0 ≤ 2.4.59 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |