Apache HTTP Server weakness with encoded question marks in backreferences
At a glance
Severity
HIGH 8.1
EPSS
EPSS 2.46 % · percentile 84 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Modified
Description
Substitution encoding issue in mod_rewrite in Apache HTTP Server 2.4.59 and earlier allows attacker to execute scripts in
directories permitted by the configuration but not directly reachable by any URL or source disclosure of scripts meant to only to be executed as CGI.
Users are recommended to upgrade to version 2.4.60, which fixes this issue.
Some RewriteRules that capture and substitute unsafely will now fail unless rewrite flag "UnsafeAllow3F" is specified.