CVE-2024-40635
containerd has an integer overflow in User ID handling
MEDIUM 4.6
En bref
- Source
- NVD
- EPSS
- EPSS 0.30 % · centile 23 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Analyzed
Description
containerd is an open-source container runtime. A bug was found in containerd prior to versions 1.6.38, 1.7.27, and 2.0.4 where containers launched with a User set as a `UID:GID` larger than the maximum 32-bit signed integer can cause an overflow condition where the container ultimately runs as root (UID 0). This could cause unexpected behavior for environments that require containers to run as a non-root user. This bug has been fixed in containerd 1.6.38, 1.7.27, and 2.04. As a workaround, ensure that only trusted images are used and that only trusted users have permissions to import images.
Faiblesses (CWE)
- CWE-190 — Débordement d'entier
Références
- https://github.com/containerd/containerd/security/advisories/GHSA-265r-hfxg-fhmg
- https://github.com/containerd/containerd/commit/05044ec0a9a75232cad458027ca83437aae3f4da
- https://github.com/containerd/containerd/commit/1a43cb6a1035441f9aca8f5666a9b3ef9e70ab20
- https://github.com/containerd/containerd/commit/cf158e884cfe4812a6c371b59e4ea9bc4c46e51a
- https://lists.debian.org/debian-lts-announce/2025/05/msg00005.html
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 4.6 | CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N | GitHub_M |
| CVSS 3.1 | MEDIUM 4.6 | CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.8 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-265r-hfxg-fhmg — containerd has an integer overflow in User ID handling
- GO-2025-3528 — containerd has an integer overflow in User ID handling in github.com/containerd/containerd
Références européennes
- ENISA EUVD · EUVD-2025-6529
- GCVE · GCVE-0-2024-40635
Avis du CERT-FR
- CERTFR-2026-AVI-0249 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0199 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0641 — Multiples vulnérabilités dans les produits Splunk · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0622 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*< 1.6.38cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*≥ 1.7.0 < 1.7.27cpe:2.3:a:linuxfoundation:containerd:*:*:*:*:*:*:*:*≥ 2.0.0 < 2.0.4cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| containerd · containerd | affected < 1.6.38 ; affected >= 1.7.0-beta.0, < 1.7.27 ; affected >= 2.0.0-beta.0, < 2.0.4 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |