CVE-2024-45034
Apache Airflow: Authenticated DAG authors could execute code on scheduler nodes
HIGH 8.8
En bref
- Source
- NVD
- EPSS
- EPSS 1.69 % · centile 77 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- apache
- Statut NVD
- Analyzed
Description
Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler, where the scheduler is not supposed to execute code submitted by the DAG author. Users are advised to upgrade to version 2.10.1 or later, which has fixed the vulnerability.
Faiblesses (CWE)
- CWE-250 — Execution with Unnecessary Privileges
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | CISA-ADP |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Avis
- GHSA-92xg-gmrq-5c3w — Apache Airflow vulnerable to Execution with Unnecessary Privileges
- PYSEC-2024-212 — Apache Airflow versions before 2.10.1 have a vulnerability that allows DAG authors to add local settings to the DAG folder and get it executed by the scheduler,
Références européennes
- ENISA EUVD · EUVD-2024-0013
- GCVE · GCVE-0-2024-45034
Configurations affectées (CPE NVD)
cpe:2.3:a:apache:airflow:*:*:*:*:*:*:*:*< 2.10.1
Produits affectés
| Produit | Versions |
|---|---|
| Apache Software Foundation · Apache Airflow | affected 0 < 2.10.1 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |