vim main.c memory corruption (vim)
En bref
- Source
- NVD
- EPSS
- EPSS 0.55 % · centile 46 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- VulDB
- Statut NVD
- Analyzed
Description
A vulnerability classified as problematic was found in vim up to 9.1.1096. This vulnerability affects unknown code of the file src/main.c. The manipulation of the argument --log leads to memory corruption. It is possible to launch the attack on the local host. Upgrading to version 9.1.1097 is able to address this issue. The patch is identified as c5654b84480822817bb7b69ebc97c174c91185e9. It is recommended to upgrade the affected component.
Faiblesses (CWE)
- CWE-119 — Opération hors des limites d'un tampon mémoire
Références
- https://vuldb.com/?id.295174
- https://vuldb.com/?ctiid.295174
- https://vuldb.com/?submit.497546
- https://github.com/vim/vim/issues/16606
- https://github.com/vim/vim/commit/c5654b84480822817bb7b69ebc97c174c91185e9
- https://github.com/vim/vim/releases/tag/v9.1.1097
- https://security.netapp.com/advisory/ntap-20250321-0005/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 4.0 | LOW 2.4 | CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N | VulDB |
| CVSS 3.1 | LOW 2.8 | CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L | VulDB |
| CVSS 3.0 | LOW 2.8 | CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L | VulDB |
| CVSS 2.0 | LOW 1.7 | AV:L/AC:L/Au:S/C:N/I:N/A:P | VulDB |
| CVSS 4.0 | LOW 2.4 | CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · cna@vuldb.com (Secondary) |
| CVSS 3.1 | LOW 2.8 | CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L | NVD · cna@vuldb.com (Secondary) |
| CVSS 3.1 | HIGH 7.8 | CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | LOW 1.7 | AV:L/AC:L/Au:S/C:N/I:N/A:P | NVD · cna@vuldb.com (Secondary) |
Références européennes
- ENISA EUVD · EUVD-2025-2085
- GCVE · GCVE-0-2025-1215
Avis du CERT-FR
- CERTFR-2025-AVI-0969 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0693 — Multiples vulnérabilités dans VMware Tanzu · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0585 — Multiples vulnérabilités dans VMware Tanzu · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:*< 9.1.1097cpe:2.3:o:netapp:bootstrap_os:-:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| vim | affected 9.1.1096 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |