CVE-2025-1474

Weak Password Requirements in mlflow/mlflow

LOW 3.8

At a glance

Source
NVD
EPSS
EPSS 0.37 % · percentile 30 ()
State
PUBLISHED
Published
Updated
Assigner
@huntr_ai
NVD status
Analyzed

Description

In mlflow/mlflow version 2.18, an admin is able to create a new user account without setting a password. This vulnerability could lead to security risks, as accounts without passwords may be susceptible to unauthorized access. Additionally, this issue violates best practices for secure user account management. The issue is fixed in version 2.19.0.

Weaknesses (CWE)

  • CWE-521 — Weak Password Requirements

References

Scores

VersionScoreVectorScored by
CVSS 3.0LOW 3.8CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N@huntr_ai
CVSS 3.1MEDIUM 5.5CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:H/A:NNVD · nvd@nist.gov (Primary)
CVSS 3.0LOW 3.8CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:NNVD · security@huntr.dev (Secondary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
mlflow · mlflow/mlflowaffected unspecified < 2.19.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD