CVE-2025-55754
Apache Tomcat: console manipulation via escape sequences in log messages
At a glance
- Source
- NVD
- EPSS
- EPSS 10.17 % · percentile 96 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Modified
Description
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Weaknesses (CWE)
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | CRITICAL 9.6 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H | CISA-ADP |
| CVSS 3.1 | CRITICAL 9.6 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Advisories
- GHSA-vfww-5hm6-hx2j — Apache Tomcat Vulnerable to Improper Neutralization of Escape, Meta, or Control Sequences
European references
- ENISA EUVD · EUVD-2025-36225
- GCVE · GCVE-0-2025-55754
CERT-FR advisories
- CERTFR-2026-AVI-0565 — Multiples vulnérabilités dans les produits Siemens · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0395 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0322 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0281 — Multiples vulnérabilités dans les produits Splunk · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0112 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-1079 — Multiples vulnérabilités dans les produits SAP · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0969 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0967 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-0933 — Multiples vulnérabilités dans Apache Tomcat · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 8.5.60 ≤ 8.5.100cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 9.0.40 < 9.0.109cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 10.0.0 < 10.0.27cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 10.1.0 < 10.1.45cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*≥ 11.0.0 < 11.0.11
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache Tomcat | affected 11.0.0-M1 ≤ 11.0.10 ; affected 10.1.0-M1 ≤ 10.1.44 ; affected 9.0.40 ≤ 9.0.108 ; affected 8.5.60 ≤ 8.5.100 ; unknown 3 < 8.5.0 ; unknown 10.0.0-M1 ≤ 10.0.27 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |