CVE-2025-58098
Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...
HIGH 8.3
En bref
- Source
- NVD
- EPSS
- EPSS 1.42 % · centile 73 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- apache
- Statut NVD
- Analyzed
Description
Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.
Faiblesses (CWE)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.3 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L | CISA-ADP |
| CVSS 3.1 | HIGH 8.3 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Références européennes
- ENISA EUVD · EUVD-2025-201408
- GCVE · GCVE-0-2025-58098
Avis du CERT-FR
- CERTFR-2026-AVI-0355 — Multiples vulnérabilités dans les produits Apple · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0199 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2025-AVI-1071 — Multiples vulnérabilités dans Apache HTTP Server · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*< 2.4.66
Produits affectés
| Produit | Versions |
|---|---|
| Apache Software Foundation · Apache HTTP Server | affected 0 < 2.4.66 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |