CVE-2025-62426
vLLM vulnerable to DoS via large Chat Completion or Tokenization requests with specially crafted `chat_template_kwargs`
MEDIUM 6.5
En bref
- Source
- NVD
- EPSS
- EPSS 0.54 % · centile 45 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Analyzed
Description
vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, the /v1/chat/completions and /tokenize endpoints allow a chat_template_kwargs request parameter that is used in the code before it is properly validated against the chat template. With the right chat_template_kwargs parameters, it is possible to block processing of the API server for long periods of time, delaying all other requests. This issue has been patched in version 0.11.1.
Faiblesses (CWE)
- CWE-770 — Allocation de ressources sans limite ni régulation
Références
- https://github.com/vllm-project/vllm/security/advisories/GHSA-69j4-grxj-j64p
- https://github.com/vllm-project/vllm/pull/27205
- https://github.com/vllm-project/vllm/commit/3ada34f9cb4d1af763fdfa3b481862a93eb6bd2b
- https://github.com/vllm-project/vllm/blob/2a6dc67eb520ddb9c4138d8b35ed6fe6226997fb/vllm/entrypoints/chat_utils.py#L1602-L1610
- https://github.com/vllm-project/vllm/blob/2a6dc67eb520ddb9c4138d8b35ed6fe6226997fb/vllm/entrypoints/openai/serving_engine.py#L809-L814
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | GitHub_M |
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | NVD · security-advisories@github.com (Secondary) |
Avis
- GHSA-69j4-grxj-j64p — vLLM vulnerable to DoS via large Chat Completion or Tokenization requests with specially crafted `chat_template_kwargs`
- PYSEC-2026-2012 — vLLM vulnerable to DoS via large Chat Completion or Tokenization requests with specially crafted `chat_template_kwargs`
Références européennes
- ENISA EUVD · EUVD-2025-198356
- GCVE · GCVE-0-2025-62426
Avis du CERT-FR
- CERTFR-2025-AVI-1138 — Multiples vulnérabilités dans VMware Tanzu Platform · cert.ssi.gouv.fr
- CERTFR-2025-AVI-1057 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*≥ 0.5.5 < 0.11.1cpe:2.3:a:vllm:vllm:0.11.1:rc0:*:*:*:*:*:*cpe:2.3:a:vllm:vllm:0.11.1:rc1:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| vllm-project · vllm | affected >= 0.5.5, < 0.11.1 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |