lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load() (InternLM lmdeploy)
En bref
- Source
- NVD
- EPSS
- EPSS 0.51 % · centile 43 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Analyzed
Rechercher sur…
Description
LMDeploy is a toolkit for compressing, deploying, and serving LLMs. Prior to version 0.11.1, an insecure deserialization vulnerability exists in lmdeploy where torch.load() is called without the weights_only=True parameter when loading model checkpoint files. This allows an attacker to execute arbitrary code on the victim's machine when they load a malicious .bin or .pt model file. This issue has been patched in version 0.11.1.
Faiblesses (CWE)
- CWE-502 — Désérialisation de données non fiables
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H | GitHub_M |
| CVSS 3.1 | HIGH 8.8 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H | NVD · security-advisories@github.com (Secondary) |
Avis
- GHSA-9pf3-7rrr-x5jh — lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()
- PYSEC-2026-1578 — lmdeploy vulnerable to Arbitrary Code Execution via Insecure Deserialization in torch.load()
Références européennes
- ENISA EUVD · EUVD-2025-205455
- GCVE · GCVE-0-2025-67729
Configurations affectées (CPE NVD)
cpe:2.3:a:internlm:lmdeploy:*:*:*:*:*:*:*:*< 0.11.1
Produits affectés
| Produit | Versions |
|---|---|
| InternLM · lmdeploy | affected < 0.11.1 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |