CVE-2025-7338

Multer vulnerable to Denial of Service via unhandled exception from malformed request

At a glance

Severity
HIGH 7.5
EPSS
EPSS 0.81 % · percentile 57 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
openjs
NVD status
Deferred

Description

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.

Scores

VersionScoreVectorScored by
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:Hopenjs
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HNVD · ce714d77-add3-4f53-aff5-83d477b104bb (Secondary)

Weaknesses (CWE)

Advisories

European references

CERT-FR advisories

Affected products

ProductVersions
expressjs · multeraffected 1.4.4-lts.1 < 2.0.2

References

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD