CVE-2026-101296

Apache Tomcat: JNDIRealm bind credential validation fails open for non-GSSAPI SASL mechanisms

At a glance

Severity
CRITICAL 9.1
EPSS
EPSS 0.63 % · percentile 50 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Awaiting Analysis

Description

A missing critical step in authentication vulnerability in Apache Tomcat when the JNDI realm was configured with with a non GSSAPI SASL authentication mechanism allowed attackers to authenticate without providing the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

Scores

VersionScoreVectorScored by
CVSS 4.0CRITICAL 9.1CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NCISA-ADP
CVSS 4.0CRITICAL 9.1CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:XNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Weaknesses (CWE)

European references

CERT-FR advisories

Affected products

ProductVersions
Apache Software Foundation · Apache Tomcataffected 11.0.0-M1 ≤ 11.0.26 ; affected 10.1.0-M1 ≤ 10.1.60 ; affected 9.0.0.M1 ≤ 9.0.122 ; affected 8.5.0 ≤ 8.5.100 ; affected 7.0.0 ≤ 7.0.109

References

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD