vllm-project vLLM Gemma4UnifiedParser gemma4.rs denial of service (vllm-project vLLM)
En bref
- Source
- NVD
- EPSS
- EPSS 0.71 % · centile 54 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- VulDB
- Statut NVD
- Analyzed
Description
A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the component Gemma4UnifiedParser. Executing a manipulation can lead to denial of service. The attack may be launched remotely. The exploit has been published and may be used. Upgrading to version 0.29.1rc0 is able to resolve this issue. This patch is called 3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9. Upgrading the affected component is advised.
Faiblesses (CWE)
- CWE-404 — Fermeture ou libération incorrecte d'une ressource
Références
- https://vuldb.com/vuln/411965
- https://vuldb.com/vuln/411965/cti
- https://vuldb.com/cve/CVE-2026-103241
- https://vuldb.com/submit/956250
- https://github.com/vllm-project/vllm/issues/50927
- https://github.com/vllm-project/vllm/pull/54303
- https://gist.github.com/Yunzez/8e98d656aa667095b513161eb056d28e
- https://github.com/vllm-project/vllm/commit/3439bad37e68ba9755a46f4f6b44a4aeaf1f60a9
- https://github.com/vllm-project/vllm/releases/tag/v0.29.1rc0
- https://github.com/vllm-project/vllm/
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 4.0 | MEDIUM 6.9 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P | VulDB |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C | VulDB |
| CVSS 3.0 | MEDIUM 5.3 | CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P/RL:O/RC:C | VulDB |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P/E:POC/RL:OF/RC:C | VulDB |
| CVSS 4.0 | MEDIUM 5.5 | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · cna@vuldb.com (Secondary) |
| CVSS 3.1 | MEDIUM 5.3 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L | NVD · cna@vuldb.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 5.0 | AV:N/AC:L/Au:N/C:N/I:N/A:P | NVD · cna@vuldb.com (Secondary) |
Avis
- PYSEC-2026-4186 — A flaw has been found in vllm-project vLLM up to 0.26.0. This vulnerability affects unknown code of the file rust/src/parser/src/unified/gemma4.rs of the compon
Références européennes
- ENISA EUVD · EUVD-2026-90191
- GCVE · GCVE-0-2026-103241
Configurations affectées (CPE NVD)
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*≤ 0.26.0
Produits affectés
| Produit | Versions |
|---|---|
| vllm-project · vLLM | affected 0.1 ; affected 0.2 ; affected 0.3 ; affected 0.4 ; affected 0.5 ; affected 0.6 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |