CVE-2026-106100
Payload: Field-level write access bypass in Payload on MongoDB
HIGH 7.1
En bref
- Source
- NVD
- EPSS
- EPSS 0.22 % · centile 12 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Analyzed
Description
Payload is a free and open source headless content management system. In @payloadcms/db-mongodb versions before 3.87.0 and canary versions before 4.0.0-canary.20, an authenticated user who can update a document can modify fields that field-level write access control does not permit that user to change. The Postgres and SQLite adapters are not affected. This issue is fixed in versions 3.87.0 and 4.0.0-canary.20.
Faiblesses (CWE)
- CWE-639 — Contournement d'autorisation par clé contrôlée par l'utilisateur (IDOR)
- CWE-915 — Affectation de masse
Références
- https://github.com/payloadcms/payload/security/advisories/GHSA-4ww4-68q3-h7g5
- https://github.com/payloadcms/payload/commit/2a69863deb0e3c87e36c1b3b17ab2d5b02fcb941
- https://github.com/payloadcms/payload/commit/8f77dffa9552885ec2710768cfee15b57e389935
- https://github.com/payloadcms/payload/releases/tag/v3.87.0
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N | GitHub_M |
| CVSS 3.1 | HIGH 7.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N | NVD · security-advisories@github.com (Secondary) |
Avis
- GHSA-4ww4-68q3-h7g5 — Payload: Field-level write access bypass in Payload on MongoDB
Références européennes
- ENISA EUVD · EUVD-2026-93515
- GCVE · GCVE-0-2026-106100
Configurations affectées (CPE NVD)
cpe:2.3:a:payloadcms:payload:*:*:*:*:*:node.js:*:*< 3.87.0cpe:2.3:a:payloadcms:payload:4.0.0:canary0:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary1:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary10:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary11:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary12:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary13:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary14:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary15:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary16:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary17:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary18:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary19:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary2:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary3:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary4:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary5:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary6:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary7:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary8:*:*:*:node.js:*:*cpe:2.3:a:payloadcms:payload:4.0.0:canary9:*:*:*:node.js:*:*
Produits affectés
| Produit | Versions |
|---|---|
| payloadcms · payload | affected < 3.87.0 ; affected >= 4.0.0-canary.0, < 4.0.0-canary.20 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |