vLLM DeepSeek-OCR image processing vulnerable to denial of service (vllm-project vllm)
At a glance
- Source
- NVD
- EPSS
- EPSS 0.40 % · percentile 34 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Analyzed
Description
vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.
Weaknesses (CWE)
- CWE-617 — Reachable Assertion
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | GitHub_M |
| CVSS 3.1 | MEDIUM 6.5 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H | NVD · security-advisories@github.com (Secondary) |
Advisories
- GHSA-gq5q-89c7-vhvx — vLLM DeepSeek-OCR image processing vulnerable to denial of service
European references
- ENISA EUVD · EUVD-2026-110032
- GCVE · GCVE-0-2026-115914
Affected configurations (NVD CPE)
cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*≥ 0.11.1 < 0.32.0
Affected products
| Product | Versions |
|---|---|
| vllm-project · vllm | affected >= 0.11.1, < 0.32.0 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |