Angular has XSS Vulnerability via Unsanitized SVG Script Attributes (angular angular)
En bref
- Source
- NVD
- EPSS
- EPSS 0.44 % · centile 38 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Rechercher sur…
Description
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0, a cross-site scripting (XSS) vulnerability has been identified in the Angular Template Compiler. The vulnerability exists because Angular’s internal sanitization schema fails to recognize the href and xlink:href attributes of SVG <script> elements as a Resource URL context. This issue has been patched in versions 19.2.18, 20.3.16, 21.0.7, and 21.1.0-rc.0.
Faiblesses (CWE)
- CWE-79 — Injection de code indirecte (XSS)
Références
- https://github.com/angular/angular/security/advisories/GHSA-jrmj-c5cx-3cw6
- https://github.com/angular/angular/pull/66318
- https://github.com/angular/angular/commit/91dc91bae4a1bbefc58bef6ef739d0e02ab44d56
- https://cert-portal.siemens.com/productcert/html/ssa-485750.html
- https://cert-portal.siemens.com/productcert/html/ssa-253495.html
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 4.0 | HIGH 8.5 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | GitHub_M |
| CVSS 4.0 | HIGH 8.5 | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | MEDIUM 6.1 | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-jrmj-c5cx-3cw6 — Angular has XSS Vulnerability via Unsanitized SVG Script Attributes
Références européennes
- ENISA EUVD · EUVD-2026-1698
- GCVE · GCVE-0-2026-22610
Avis du CERT-FR
- CERTFR-2026-AVI-1165 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0523 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0224 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:*≤ 18.2.14cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:*≥ 19.0.0 < 19.2.18cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:*≥ 20.0.0 < 20.3.16cpe:2.3:a:angular:angular:*:*:*:*:*:node.js:*:*≥ 21.0.0 < 21.0.7cpe:2.3:a:angular:angular:21.1.0:next0:*:*:*:node.js:*:*cpe:2.3:a:angular:angular:21.1.0:next1:*:*:*:node.js:*:*cpe:2.3:a:angular:angular:21.1.0:next2:*:*:*:node.js:*:*cpe:2.3:a:angular:angular:21.1.0:next3:*:*:*:node.js:*:*cpe:2.3:a:angular:angular:21.1.0:next4:*:*:*:node.js:*:*
Produits affectés
| Produit | Versions |
|---|---|
| angular · angular | affected >= 21.1.0-next.0, < 21.1.0-rc.0 ; affected >= 21.0.0-next.0, < 21.0.7 ; affected >= 20.0.0-next.0, < 20.3.16 ; affected < 19.2.18 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |