CVE-2026-24733

Apache Tomcat: Security constraint bypass with HTTP/0.9

En bref

Sévérité
MEDIUM 6.5
EPSS
EPSS 0.55 % · centile 46 (2026-10-27)
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
apache
Statut NVD
Modified

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1MEDIUM 6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NCISA-ADP
CVSS 3.1LOW 3.7CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:NNVD · nvd@nist.gov (Primary)
CVSS 3.1MEDIUM 6.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Faiblesses (CWE)

Avis

Références européennes

Avis du CERT-FR

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Apache Software Foundation · Apache Tomcataffected 11.0.0-M1 ≤ 11.0.14 ; affected 10.1.0-M1 ≤ 10.1.49 ; affected 9.0.0.M1 ≤ 9.0.112 ; affected 0 ≤ 8.5.100

Références

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD