Apache Spark: XSS Vulnerability in Spark Web 3.5.4 (Apache Software Foundation Apache Spark)

CVE-2026-32773
MEDIUM 6.1

At a glance

Source
NVD
EPSS
EPSS 0.41 % Β· percentile 36 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

There is a lack of XSS escaping in the Spark History Server prior to 3.5.8 which allows a malicious Spark job to generate arbitrary unescaped frontend code which could lead to a minimal privilege escalation in browser. Users are encouraged to upgrade to Spark 3.5.8 or later. This CVE is marked as "low" since the path to exploit requires both relatively high permissions (ability to launch a Spark job) and requires tricking a user with higher permissions to log in and visit the Spark history web page. Users are encouraged to upgrade their Spark history servers to Spark 3.5.8 or later.

Weaknesses (CWE)

  • CWE-80 β€” Improper Neutralization of Script-Related HTML Tags in a Web Page

References

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NCISA-ADP
CVSS 3.1MEDIUM 6.1CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NNVD Β· 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation Β· Apache Sparkaffected 3.0.0 < 3.5.8

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST β€” attribution requested
ENISA EUVDENISA β€” reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain β€” this product uses data from the NVD API but is not endorsed or certified by the NVD