CVE-2026-34059
Apache HTTP Server: mod_proxy_ajp: Heap Over-Read and memory disclosure in ajp_parse_data()
At a glance
- Severity
- HIGH 7.5
- EPSS
- EPSS 0.39 % · percentile 33 (2026-10-27)
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Analyzed
Description
Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | CISA-ADP |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Weaknesses (CWE)
European references
- ENISA EUVD · EUVD-2026-26948
- GCVE · GCVE-0-2026-34059
CERT-FR advisories
- CERTFR-2026-AVI-0962 — Multiples vulnérabilités dans les produits Tenable · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0905 — Multiples vulnérabilités dans Tenable Security Center · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0608 — Multiples vulnérabilités dans Microsoft Azure Linux · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0530 — Multiples vulnérabilités dans Apache HTTP Server · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*< 2.4.67
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache HTTP Server | affected 0 ≤ 2.4.66 |
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/05/04/17
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |