Flowise: Flowise Parameter Override Bypass Remote Command Execution (FlowiseAI Flowise)

CVE-2026-41268
HIGH 7.7

En bref

Source
NVD
EPSS
EPSS 17.44 % · centile 97 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
GitHub_M
Statut NVD
Analyzed

Description

Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.0, Flowise is vulnerable to a critical unauthenticated remote command execution (RCE) vulnerability. It can be exploited via a parameter override bypass using the FILE-STORAGE:: keyword combined with a NODE_OPTIONS environment variable injection. This allows for the execution of arbitrary system commands with root privileges within the containerized Flowise instance, requiring only a single HTTP request and no authentication or knowledge of the instance. This vulnerability is fixed in 3.1.0.

Faiblesses (CWE)

  • CWE-20 — Validation d'entrée incorrecte

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.0HIGH 7.7CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:LGitHub_M
CVSS 3.1CRITICAL 9.8CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HNVD · nvd@nist.gov (Primary)
CVSS 3.0HIGH 7.7CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:LNVD · security-advisories@github.com (Secondary)

Avis

Références européennes

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
FlowiseAI · Flowiseaffected < 3.1.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD