CVE-2026-44578

Next.js: Server-side request forgery in applications using WebSocket upgrades

En bref

Sévérité
HIGH 8.6
EPSS
EPSS 35.54 % · centile 98 (2026-10-28)
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
GitHub_M
Statut NVD
Modified

Description

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1HIGH 8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:NGitHub_M
CVSS 3.1HIGH 8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:Nredhat-SADP
CVSS 3.1HIGH 8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:NNVD · security-advisories@github.com (Secondary)
CVSS 3.1HIGH 8.6CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:NNVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary)

Faiblesses (CWE)

Avis

Références européennes

Avis du CERT-FR

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
vercel · next.jsaffected >= 16.0.0, < 16.2.5 ; affected >= 13.4.13, < 15.5.16

Références

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD