CVE-2026-45109
Next.js: Middleware / Proxy bypass in App Router applications via segment-prefetch routes
HIGH 7.5
En bref
- Source
- NVD
- EPSS
- EPSS 0.60 % · centile 49 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- GitHub_M
- Statut NVD
- Modified
Description
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
Faiblesses (CWE)
- CWE-288 — Contournement d'authentification par un canal ou un chemin alternatif
- CWE-358 — Contrôle de sécurité d'un standard mal implémenté
Références
- https://github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6
- https://access.redhat.com/security/cve/CVE-2026-45109
- https://bugzilla.redhat.com/show_bug.cgi?id=2477190
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45109.json
- https://access.redhat.com/errata/RHSA-2026:40974
- https://access.redhat.com/errata/RHSA-2026:37272
- https://access.redhat.com/errata/RHSA-2026:34608
- https://access.redhat.com/errata/RHSA-2026:54435
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | GitHub_M |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | redhat-SADP |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · security-advisories@github.com (Secondary) |
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · 0b0ca135-0b70-47e7-9f44-1890c2a1c46c (Secondary) |
Avis
- GHSA-26hh-7cqf-hhc6 — Next.js has a Middleware / Proxy bypass in App Router applications via segment-prefetch routes - Incomplete Fix Follow-Up
Références européennes
- ENISA EUVD · EUVD-2026-30085
- GCVE · GCVE-0-2026-45109
Avis du CERT-FR
- CERTFR-2026-AVI-0901 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 15.2.0 < 15.5.18cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:*≥ 16.0.0 < 16.2.6
Produits affectés
| Produit | Versions |
|---|---|
| vercel · next.js | affected >= 15.2.0, < 15.5.17 ; affected >= 16.0.0, < 16.2.6 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |