CVE-2026-46605
Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Incomplete authorization during destination removal
MEDIUM 4.3
En bref
- Source
- NVD
- EPSS
- EPSS 0.35 % · centile 28 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- apache
- Statut NVD
- Analyzed
Description
Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6. Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.
Faiblesses (CWE)
- CWE-285 — Autorisation incorrecte
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 4.3 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L | CISA-ADP |
| CVSS 3.1 | MEDIUM 4.3 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L | NVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary) |
Avis
- GHSA-cpw7-g3p5-qrfq — Apache ActiveMQ server has an incomplete authorization workflow
Références européennes
- ENISA EUVD · EUVD-2026-33575
- GCVE · GCVE-0-2026-46605
Avis du CERT-FR
- CERTFR-2026-AVI-1094 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-0958 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*< 5.19.7cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*≥ 6.0.0 < 6.2.6cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*< 5.19.7cpe:2.3:a:apache:activemq_broker:*:*:*:*:*:*:*:*≥ 6.0.0 < 6.2.6
Produits affectés
| Produit | Versions |
|---|---|
| Apache Software Foundation · Apache ActiveMQ Broker | affected 0 < 5.19.7 ; affected 6.0.0 < 6.2.6 |
| Apache Software Foundation · Apache ActiveMQ All | affected 0 < 5.19.7 ; affected 6.0.0 < 6.2.6 |
| Apache Software Foundation · Apache ActiveMQ | affected 0 < 5.19.7 ; affected 6.0.0 < 6.2.6 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |