Apache ActiveMQ: Authenticated low-privilege Web users retain Jolokia broker-management capability by default
At a glance
Severity
HIGH 8.8
EPSS
EPSS 0.44 % · percentile 38 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed
Description
Incorrect Default Permissions vulnerability in Apache ActiveMQ.
This issue affects Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.
The default Jolokia authorization settings granted non-admin (low-privilege) web-login accounts access to Jolokia operations which allowed executing broker management operations meant for admins such as addQueue and removeQueue.
Users are recommended to upgrade to version 6.2.6 or 5.19.7, which fixes the issue.