CVE-2026-66422

Apache Tomcat: Servlet role references can bypass declarative role constraints

HIGH 8.1

En bref

Source
NVD
EPSS
EPSS 0.43 % · centile 37 ()
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
apache
Statut NVD
Analyzed

Description

Improper Authorization vulnerability in Apache Tomcat cause by security-role-ref definitions being incorrectly used as role aliases within the Realm in additional to the correct usage with Request.isUserInRole(). This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.25 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.46 through 8.5.100, from 7.0.97 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Faiblesses (CWE)

  • CWE-285 — Autorisation incorrecte

Références

Scores

VersionScoreVecteurÉvalué par
CVSS 3.1HIGH 8.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:HCISA-ADP
CVSS 3.1HIGH 8.1CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:HNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Références européennes

Avis du CERT-FR

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Apache Software Foundation · Apache Tomcataffected 11.0.0-M1 ≤ 11.0.24 ; affected 10.1.0-M1 ≤ 10.1.57 ; affected 9.0.25 ≤ 9.0.120 ; affected 8.5.46 ≤ 8.5.100 ; affected 7.0.97 ≤ 7.0.109 ; unaffected 0 < 7.0.97

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD