CVE-2026-7210

The expat and elementtree parsers use insufficient entropy for XML hash-flooding protection

En bref

Sévérité
MEDIUM 6.3
EPSS
EPSS 0.67 % · centile 52 (2026-10-27)
État
PUBLISHED
Publiée
Mise à jour
Attribuée par
PSF
Statut NVD
Modified

Description

`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

Scores

VersionScoreVecteurÉvalué par
CVSS 4.0MEDIUM 6.3CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NPSF
CVSS 4.0MEDIUM 6.3CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:XNVD · cna@python.org (Secondary)
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HNVD · nvd@nist.gov (Primary)

Faiblesses (CWE)

Références européennes

Avis du CERT-FR

Configurations affectées (CPE NVD)

Produits affectés

ProduitVersions
Python Software Foundation · CPythonaffected 0 < 3.10.22 ; affected 3.11.0 < 3.11.16 ; affected 3.12.0 < 3.12.14 ; affected 3.13.0 < 3.13.14 ; affected 3.14.0 < 3.14.6 ; affected 3.15.0a1 < 3.15.0b2

Références

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD