CVE-2026-73180

Apache Tomcat: Authenticated WebSocket session survives end of HTTP session

At a glance

Severity
MEDIUM 6.8
EPSS
EPSS 0.44 % · percentile 38 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

Insufficient Session Expiration vulnerability in Apache Tomcat meant that if the session ID for an authenticated HTTP session was changed after a WebSocket connection had been established under that authenticated HTTP session, the WebSokcet session would not be closed as required by the Jakarta WebSocket specification when the HTTP session ended. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.

Scores

VersionScoreVectorScored by
CVSS 3.1MEDIUM 6.8CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NCISA-ADP
CVSS 3.1MEDIUM 6.8CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Weaknesses (CWE)

European references

CERT-FR advisories

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Tomcataffected 11.0.0-M1 ≤ 11.0.24 ; affected 10.1.0-M1 ≤ 10.1.57 ; affected 9.0.0.M1 ≤ 9.0.120 ; affected 8.5.0 ≤ 8.5.100 ; affected 7.0.43 ≤ 7.0.109 ; unaffected 0 < 7.0.43

References

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
CERT-FR (ANSSI)Licence Ouverte / Etalab 2.0
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD