Apache Tomcat: Bypass of security constraints for WebSocket endpoints
At a glance
Severity
CRITICAL 9.8
EPSS
EPSS 0.57 % · percentile 47 (2026-10-27)
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Awaiting Analysis
Description
Authentication Bypass by Alternate Name vulnerability in Apache Tomcat allowed the security constraints for any WebSocket endpoint to be bypassed.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M1 through 9.0.121.
The following versions were EOS at the time the CVE was created but are
known to be affected: from 8.5.0 through 8.5.100, from 7.0.43 through 7.0.109. Other unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.26, 10.1.60 or 9.0.122, which fix the issue.