CVE-2026-84360
Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools
HIGH 8.1
At a glance
- Source
- NVD
- EPSS
- EPSS 0.42 % · percentile 36 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- GitHub_M
- NVD status
- Deferred
Description
Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.
Weaknesses (CWE)
- CWE-288 — Authentication Bypass Using an Alternate Path or Channel
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H | GitHub_M |
| CVSS 3.1 | HIGH 8.1 | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H | NVD · security-advisories@github.com (Secondary) |
Advisories
- GHSA-vc32-4gwf-77xp — Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools
- GO-2026-6799 — Nginx UI: OTP secure-session step-up can be bypassed via MCP configuration tools in github.com/0xJacky/Nginx-UI
European references
- ENISA EUVD · EUVD-2026-97907
- GCVE · GCVE-0-2026-84360
Affected products
| Product | Versions |
|---|---|
| 0xJacky · nginx-ui | affected < 2.4.1 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |