undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression (undici undici)
At a glance
- Source
- NVD
- EPSS
- EPSS 0.41 % · percentile 35 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- openjs
- NVD status
- Analyzed
Description
undici bundles a WebSocket client whose permessage-deflate size-limit cleanup removes all listeners from the internal zlib inflate stream, including its error listener, while that stream can still emit. When a remote peer sends a compressed payload that crosses the built-in 128 MiB decompressed-payload limit and then contains a malformed DEFLATE byte, the inflate stream emits a data error with no listener attached, which Node.js treats as a fatal unhandled error and terminates the entire process. Exploitation is remote and unauthenticated, requires no application mistake, and is asymmetric, since roughly 130 KB on the wire expands past the limit and crashes the process, and reconnecting can repeat the crash. This affects undici versions from 6.25.0 up to 6.28.1, from 7.28.0 up to 7.29.1, and from 8.1.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.
Weaknesses (CWE)
- CWE-248 — Uncaught Exception
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | MEDIUM 5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H | openjs |
| CVSS 3.1 | MEDIUM 5.9 | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H | NVD · ce714d77-add3-4f53-aff5-83d477b104bb (Secondary) |
Advisories
- GHSA-3wwx-pv8p-q78v — undici vulnerable to Denial of Service via unhandled error in WebSocket permessage-deflate decompression
European references
- ENISA EUVD · EUVD-2026-71603
- GCVE · GCVE-0-2026-85024
CERT-FR advisories
- CERTFR-2026-AVI-1378 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1336 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
- CERTFR-2026-AVI-1233 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*≥ 6.25.0 < 6.28.1cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*≥ 7.28.0 < 7.29.1cpe:2.3:a:nodejs:undici:*:*:*:*:*:node.js:*:*≥ 8.1.0 < 8.10.2
Affected products
| Product | Versions |
|---|---|
| undici · undici | affected 6.25.0 < 6.28.1 ; unaffected 6.28.1 ; affected 7.28.0 < 7.29.1 ; unaffected 7.29.1 ; affected 8.1.0 < 8.10.2 ; unaffected 8.10.2 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |