GStreamer
10 vulnérabilités publiées citent ce produit.
Tel que les CNA l’écrivent dans leurs fiches CVE (éditeur et produit) ; les versions sont les leurs.
| CVE | Versions vulnérables | Titre | Sévérité | Publiée | EPSS | Exploitation |
|---|---|---|---|---|---|---|
| CVE-2022-1924 | 1.20.3 | DOS / potential heap overwrite in mkv demuxing using lzo decompression. Integer overflow in matroskademux element in lzo decompression funct | HIGH 7.8 | 0.4 % | ||
| CVE-2022-1923 | 1.20.3 | DOS / potential heap overwrite in mkv demuxing using bzip decompression. Integer overflow in matroskademux element in bzip decompression fun | HIGH 7.8 | 0.4 % | ||
| CVE-2022-2122 | 1.20.3 | DOS / potential heap overwrite in qtdemux using zlib decompression. Integer overflow in qtdemux element in qtdemux_inflate function which ca | HIGH 7.8 | 0.5 % | ||
| CVE-2022-1925 | 1.20.3 | DOS / potential heap overwrite in mkv demuxing using HEADERSTRIP decompression. Integer overflow in matroskaparse element in gst_matroska_de | HIGH 7.8 | 0.5 % | ||
| CVE-2022-1922 | 1.20.3 | DOS / potential heap overwrite in mkv demuxing using zlib decompression. Integer overflow in matroskademux element in gst_matroska_decompres | HIGH 7.8 | 0.5 % | ||
| CVE-2022-1920 | 1.20.3 | Integer overflow in matroskademux element in gst_matroska_demux_add_wvpk_header function which allows a heap overwrite while parsing matrosk | HIGH 7.8 | 0.5 % | ||
| CVE-2022-1921 | 1.20.3 | Integer overflow in avidemux element in gst_avi_demux_invert function which allows a heap overwrite while parsing avi files. Potential for a | HIGH 7.8 | 0.5 % | ||
| CVE-2021-3522 | All GStreamer version before 1.18.4 | GStreamer before 1.18.4 may perform an out-of-bounds read when handling certain ID3v2 tags. | MEDIUM 5.5 | 5.4 % | ||
| CVE-2021-3185 | Fixed in gst-plugins-bad-1.18.1 | A flaw was found in the gstreamer h264 component of gst-plugins-bad before v1.18.1 where when parsing a h264 header, an attacker could cause | CRITICAL 9.8 | 2.5 % | ||
| CVE-2020-6095 | GStreamer gst-rtsp-server 1.14.5 | An exploitable denial of service vulnerability exists in the GstRTSPAuth functionality of GStreamer/gst-rtsp-server 1.14.5. A specially craf | HIGH 7.5 | 2.9 % |