yarn

4 vulnérabilités publiées citent ce produit.

Tel que les CNA l’écrivent dans leurs fiches CVE (éditeur et produit) ; les versions sont les leurs.

CVEVersions vulnérablesTitreSévéritéPubliéeEPSSExploitation
CVE-2021-4435corrigé en 1.22.13Yarn: untrusted search pathHIGH 7.80.3 %
CVE-2019-15608Fixed in 1.19.0The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cacMEDIUM 5.91.8 %
CVE-2020-8131Fixed Version: 1.22.0Arbitrary filesystem write vulnerability in Yarn before 1.22.0 allows attackers to write to any path on the filesystem and potentially lead HIGH 7.55.2 %
CVE-2019-10773All versions prior to version 1.21.1In Yarn before 1.21.1, the package install functionality can be abused to generate arbitrary symlinks on the host filesystem by using speciaHIGH 7.81.5 %