Apache Software Foundation Apache Struts
33 published vulnerabilities name this product.
As the CNAs write it in their CVE records (vendor and product); the versions are theirs.
| CVE | Vulnerable versions | Title | Severity | Published | EPSS | Exploitation |
|---|---|---|---|---|---|---|
| CVE-2026-104714 | 2.0.0 – 2.3.37 ; 2.5.0 – 2.5.33 ; 6.0.0 – 6.11.0 ; … | Apache Struts: Shared message formatter exposes date and time values across concurrent requests | HIGH 8.8 | 0.5 % | ||
| CVE-2026-104713 | 2.1.8 – 2.3.37 ; 2.5.0 – 2.5.33 ; 6.0.0 – 6.11.0 ; … | Apache Struts: Unbounded request body read in the REST plugin | MEDIUM 6.5 | 0.6 % | ||
| CVE-2026-104712 | 2.5.14 – 2.5.33 ; 6.0.0 – 6.11.0 ; 7.0.0 – 7.3.0 | Apache Struts: Disproportionate response size when rendering BigDecimal request parameters | HIGH 7.5 | 0.8 % | ||
| CVE-2026-104711 | 2.0.0 – 2.3.37 ; 2.5.0 – 2.5.33 ; 6.0.0 – 6.11.0 ; … | Apache Struts: OGNL injection in the legacy RESTful action mapper | CRITICAL 9.8 | 1.4 % | ||
| CVE-2026-73632 | 7.2.1 | Apache Struts: Shared serialization state in the JSON plugin | MEDIUM 4.3 | 0.4 % | ||
| CVE-2026-73631 | 7.2.1 | Apache Struts: Shared parsing state in the JSON plugin | MEDIUM 4.3 | 0.4 % | ||
| CVE-2026-73635 | 2.0.0 – 2.3.37 ; 2.5.0 – 2.5.33 ; 6.0.0 – 6.10.0 ; … | Apache Struts: Unbounded growth of localized-text caches driven by the request locale | HIGH 7.5 | 0.5 % | ||
| CVE-2026-73634 | 6.0.0 – 6.10.0 ; 7.0.0 – 7.2.1 | Apache Struts: Unbounded read of a Content Security Policy violation report | HIGH 7.5 | 0.4 % | ||
| CVE-2026-73633 | 2.1.8 – 2.3.37 ; 2.5.0 – 2.5.33 ; 6.0.0 – 6.10.0 ; … | Apache Struts: Unbounded read of a JSON request body | HIGH 7.5 | 0.7 % | ||
| CVE-2025-68493 | 2.0.0 – < 2.2.1 | Apache Struts, Apache Struts: XXE vulnerability in outdated XWork component | HIGH 8.1 | 50 % | ||
| CVE-2025-66675 | 2.0.0 – 6.7.* ; 7.0.0 – 7.0.* | Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) - version ranges fixed | HIGH 8.2 | 0.6 % | ||
| CVE-2025-64775 | 2.0.0 – 6.7.0 ; 7.0.0 – 7.0.3 | Apache Struts: File leak in multipart request processing causes disk exhaustion (DoS) | HIGH 7.5 | 1.5 % | ||
| CVE-2024-53677 | 2.0.0 – < 6.4.0 | Apache Struts: Mixing setters for uploaded files and normal fields can allow bypass file upload checks | CRITICAL 9.5 | 72 % | ||
| CVE-2023-50164 | 2.0.0 – 2.5.32 ; 6.0.0 – 6.3.0.1 | Apache Struts: File upload component had a directory traversal vulnerability | CRITICAL 9.8 | 81 % | ||
| CVE-2023-41835 | 2.0.0 – 2.5.31 ; 6.1.2.1 – 6.3.0 | Apache Struts: excessive disk usage | HIGH 7.5 | 7.3 % | ||
| CVE-2023-34396 | ≤ 2.5.30 ; ≤ 6.1.2 | Apache Struts: DoS via OOM owing to no sanity limit on normal form fields in multipart forms | HIGH 7.5 | 5.5 % | ||
| CVE-2023-34149 | ≤ 2.5.30 ; ≤ 6.1.2 | Apache Struts: DoS via OOM owing to not properly checking of list bounds | MEDIUM 6.5 | 5.4 % | ||
| CVE-2021-31805 | 2.0.0 to 2.5.29 | Forced OGNL evaluation, when evaluated on raw not validated user input in tag attributes, may lead to RCE. | CRITICAL 9.8 | 85 % | ||
| CVE-2020-17530 | Struts 2.0.0 - Struts 2.5.25 | Forced OGNL evaluation, when evaluated on raw user input in tag attributes, may lead to remote code execution. Affected software : Apache St | CRITICAL 9.8 | 96 % | KEV | |
| CVE-2015-2992 | before 2.3.20 | Apache Struts before 2.3.20 has a cross-site scripting (XSS) vulnerability. | MEDIUM 6.1 | 5.8 % | ||
| CVE-2018-11776 | 2.3 to 2.3.34 ; 2.5 to 2.5.16 | Apache Struts versions 2.3 to 2.3.34 and 2.5 to 2.5.16 suffer from possible Remote Code Execution when alwaysSelectFullNamespace is true (ei | HIGH 8.1 | 100 % | KEV | |
| CVE-2018-1327 | Apache Struts 2.1.1 to 2.5.14.1 | The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request wit | HIGH 7.5 | 8.6 % | ||
| CVE-2017-15707 | 2.5 to 2.5.14 | In Apache Struts 2.5 to 2.5.14, the REST Plugin is using an outdated JSON-lib library which is vulnerable and allow perform a DoS attack usi | MEDIUM 6.2 | 4.9 % | ||
| CVE-2017-9804 | 2.3.7 - 2.3.33 ; 2.5 - 2.5.12 | In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValida | HIGH 7.5 | 8.2 % | ||
| CVE-2017-9793 | 2.3.7 - 2.3.33 ; 2.5 - 2.5.12 ; 2.1.x series | The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable | HIGH 7.5 | 8.8 % | ||
| CVE-2017-12611 | 2.0.0 - 2.3.33 ; 2.5 - 2.5.10.1 | In Apache Struts 2.0.0 through 2.3.33 and 2.5 through 2.5.10.1, using an unintentional expression in a Freemarker tag instead of string lite | CRITICAL 9.8 | 87 % | ||
| CVE-2016-8738 | 2.5 - 2.5.5 | In Apache Struts 2.5 through 2.5.5, if an application allows entering a URL in a form field and the built-in URLValidator is used, it is pos | MEDIUM 5.9 | 3.3 % | ||
| CVE-2016-6795 | 2.3.x before 2.3.31 ; 2.5.x before 2.5.5 | In the Convention plugin in Apache Struts 2.3.x before 2.3.31, and 2.5.x before 2.5.5, it is possible to prepare a special URL which will be | CRITICAL 9.8 | 8.2 % | ||
| CVE-2017-9805 | Apache Struts before 2.3.34 and 2.5.x before 2.5.13 | The REST Plugin in Apache Struts 2.1.1 through 2.3.x before 2.3.34 and 2.5.x before 2.5.13 uses an XStreamHandler with an instance of XStrea | HIGH 8.1 | 99 % | KEV | |
| CVE-2017-9787 | 2.3.x prior to 2.3.33 ; 2.5 to 2.5.10.1 | When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Stru | HIGH 7.5 | 11 % | ||
| CVE-2017-7672 | 2.5 to 2.5.10.1 | If an application allows enter an URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will | MEDIUM 5.9 | 9.8 % | ||
| CVE-2017-9791 | 2.1.x series ; 2.3.x series | The Struts 1 plugin in Apache Struts 2.1.x and 2.3.x might allow remote code execution via a malicious field value passed in a raw message t | CRITICAL 9.8 | 99 % | KEV | |
| CVE-2017-5638 | 2.3.x before 2.3.32 ; 2.5.x before 2.5.10.1 | The Jakarta Multipart parser in Apache Struts 2 2.3.x before 2.3.32 and 2.5.x before 2.5.10.1 has incorrect exception handling and error-mes | CRITICAL 9.8 | 100 % | KEV |