Red Hat Ansible

29 vulnérabilités publiées citent ce produit.

Tel que les CNA l’écrivent dans leurs fiches CVE (éditeur et produit) ; les versions sont les leurs.

CVEVersions vulnérablesTitreSévéritéPubliéeEPSSExploitation
CVE-2020-143322.9.12 ; 2.8.14A flaw was found in the Ansible Engine when using module_args. Tasks executed with check mode (--check-mode) do not properly neutralize sensMEDIUM 5.50.4 %
CVE-2020-143302.10.0An Improper Output Neutralization for Logs flaw was found in Ansible when using the uri module, where sensitive data is exposed to content aMEDIUM 5.50.6 %
CVE-2020-10744ansible-engine 2.7.18 and prior ; ansible-engine 2.8.12 and prior ; ansible-engine 2.9.9 and prior ; …An incomplete fix was found for the fix of the flaw CVE-2020-1733 ansible: insecure temporary directory when running become_user from becomeMEDIUM 5.00.3 %
CVE-2020-1746ansible-engine versions 2.7.x before 2.7.17 ; ansible-engine versions 2.8.x before 2.8.11 ; ansible-engine versions 2.9.x before 2.9.7 ; …A flaw was found in the Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 MEDIUM 5.00.4 %
CVE-2020-10685ansible-engine versions 2.7.x before 2.7.17 ; ansible-engine 2.8.x before 2.8.11 ; ansible-engine 2.9.x before 2.9.7 ; …A flaw was found in Ansible Engine affecting Ansible Engine versions 2.7.x before 2.7.17 and 2.8.x before 2.8.11 and 2.9.x before 2.9.7 as wMEDIUM 5.50.4 %
CVE-2020-10691all ansible-engine versions 2.9.x prior to 2.9.7An archive traversal flaw was found in all ansible-engine versions 2.9.x prior to 2.9.7, when running ansible-galaxy collection install. WheMEDIUM 5.20.3 %
CVE-2019-149052.9.x before 2.9.3 ; 2.8.x before 2.8.8 ; 2.7.x before 2.7.16 ; …A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in AnsibHIGH 7.30.7 %
CVE-2020-10684all Ansible 2.7.x versions prior to 2.7.17 ; all Ansible 2.8.x versions prior to 2.8.9 ; all Ansible 2.9.x versions prior to 2.9.6A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_faHIGH 7.90.3 %
CVE-2020-17382.7.x, 2.8.x, 2.9.xA flaw was found in Ansible Engine when the module package or service is used and the parameter 'use' is not specified. If a previous task iLOW 3.90.4 %
CVE-2020-17402.7.x, 2.8.x, 2.9.xA flaw was found in Ansible Engine when using Ansible Vault for editing encrypted files. When a user executes "ansible-vault edit", another MEDIUM 4.70.4 %
CVE-2020-17352.7.x, 2.8.x, 2.9.xA flaw was found in the Ansible Engine when the fetch module is used. An attacker could intercept the module, inject a new path, and then chMEDIUM 4.60.5 %
CVE-2020-17362.7.x, 2.8.x, 2.9.xA flaw was found in Ansible Engine when a file is moved using atomic_move primitive as the file mode cannot be specified. This sets the destLOW 3.30.4 %
CVE-2020-1753all Ansible 2.7.x versions prior to 2.7.17 ; all Ansible 2.8.x versions prior to 2.8.11 ; all Ansible 2.9.x versions prior to 2.9.7A security flaw was found in Ansible Engine, all Ansible 2.7.x versions prior to 2.7.17, all Ansible 2.8.x versions prior to 2.8.11 and all MEDIUM 5.50.5 %
CVE-2020-17392.7.16 and prior ; 2.8.8 and prior ; 2.9.5 and priorA flaw was found in Ansible 2.7.16 and prior, 2.8.8 and prior, and 2.9.5 and prior when a password is set with the argument "password" of svLOW 3.90.4 %
CVE-2020-17332.7.17 and prior ; 2.8.9 and prior ; 2.9.6 and priorA race condition flaw was found in Ansible Engine 2.7.17 and prior, 2.8.9 and prior, 2.9.6 and prior when running a playbook with an unpriviMEDIUM 5.00.4 %
CVE-2020-17372.7.17 and prior ; 2.8.9 and prior ; 2.9.6 and prior ; …A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip moHIGH 7.80.4 %
CVE-2020-1734n/aA flaw was found in the pipe lookup plugin of ansible. Arbitrary commands can be run, when the pipe lookup plugin uses subprocess.Popen() wiHIGH 7.40.5 %
CVE-2019-14864Ansible versions 2.9.x before 2.9.1 ; Ansible versions 2.8.x before 2.8.7 ; Ansible versions 2.7.x before 2.7.15Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it MEDIUM 6.51.9 %
CVE-2019-10217ansible 2.8.0 before 2.8.4A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fieldsMEDIUM 6.51.9 %
CVE-2019-10206all 2.8.x before 2.8.4 ; all 2.7.x before 2.7.13 ; all 2.6.x before 2.6.19ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passMEDIUM 6.51.5 %
CVE-2019-14858ansible_engine-2.x up to 2.8 ; ansible_tower-3.x up to 3.5A vulnerability was found in Ansible engine 2.x up to 2.8 and Ansible tower 3.x up to 3.5. When a module has an argument_spec with sub paramHIGH 7.30.4 %
CVE-2019-14846all ansible_engine-2.x and ansible_engine-3.x up to ansible_engine-3.5In Ansible, all Ansible Engine versions up to ansible-engine 2.8.5, ansible-engine 2.7.13, ansible-engine 2.6.19, were logging at the DEBUG HIGH 7.80.5 %
CVE-2019-10156fixed in 2.6.18 ; fixed in 2.7.12 ; fixed in 2.8.2A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of MEDIUM 5.41.8 %
CVE-2019-38282.5.15 ; 2.6.14 ; 2.7.8Ansible fetch module before versions 2.5.15, 2.6.14, 2.7.8 has a path traversal vulnerability which allows copying and overwriting files outMEDIUM 4.20.5 %
CVE-2018-16876before 2.5.14 ; before 2.6.11 ; before 2.7.5ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leMEDIUM 5.32.5 %
CVE-2018-168592.8 and olderExecution of Ansible playbooks on Windows platforms with PowerShell ScriptBlock logging and Module logging enabled can allow for 'become' paMEDIUM 4.40.5 %
CVE-2016-86142.2.0A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary toHIGH 7.52.5 %
CVE-2016-86282.2.0Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to creCRITICAL 9.13.2 %
CVE-2016-86472.2.1.0An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in MEDIUM 4.91.4 %