GHSA-4rmr-c2jx-vx27
Mustache remote code injection vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-0323
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
In Mustache.php v2.0.0 through v2.14.0, Sections tag can lead to arbitrary php code execution even if strict_callables is true when section value is controllable.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · mustache/mustache | introduced 2.0.0, fixed 2.14.1 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2022-0323 ADVISORY
- https://github.com/bobthecow/mustache.php/commit/579ffa5c96e1d292c060b3dd62811ff01ad8c24e WEB
- https://github.com/FriendsOfPHP/security-advisories/blob/master/mustache/mustache/CVE-2022-0323.yaml WEB
- https://github.com/bobthecow/mustache.php PACKAGE
- https://github.com/bobthecow/mustache.php/releases/tag/v2.14.1 WEB
- https://huntr.dev/bounties/a5f5a988-aa52-4443-839d-299a63f44fb7 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |