GHSA-5rrg-rr89-x9mv

Ansible Exposes Sensitive Information

En bref

Publiée
Mise à jour
CVE
CVE-2021-20228
Alias
PYSEC-2021-1
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

A flaw was found in the Ansible Engine prior to 2.10.6rc1, 2.9.18rc1, and 2.8.19rc1, where sensitive info is not masked by default and is not protected by the `no_log` feature when using the sub-option feature of the basic.py module. This flaw allows an attacker to obtain sensitive information. The highest threat from this vulnerability is to confidentiality.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 2.10.0a1, fixed 2.10.6rc1
PyPI · ansibleintroduced 2.9.0a1, fixed 2.9.18rc1
PyPI · ansibleintroduced 0, fixed 2.8.19rc1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database