PYSEC-2023-267
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-50783
- Alias
- BIT-airflow-2023-50783, GHSA-5938-79hg-xh3q
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Description
Apache Airflow, versions before 2.8.0, is affected by a vulnerability that allows an authenticated user without the variable edit permission, to update a variable. This flaw compromises the integrity of variable management, potentially leading to unauthorized data modification. Users are recommended to upgrade to 2.8.0, which fixes this issue
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.8.0 |
Références
- https://github.com/apache/airflow/pull/33932 FIX
- https://lists.apache.org/thread/rs7cr3yp726mb89s1m844hy9pq7frgcn ARTICLE
- https://lists.apache.org/thread/rs7cr3yp726mb89s1m844hy9pq7frgcn WEB
- http://www.openwall.com/lists/oss-security/2023/12/21/4 ARTICLE
- http://www.openwall.com/lists/oss-security/2023/12/21/4 WEB
- https://github.com/advisories/GHSA-5938-79hg-xh3q ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |