PYSEC-2024-46

At a glance

Published
Updated
CVE
CVE-2024-28746
Aliases
BIT-airflow-2024-28746, GHSA-h574-6646-vfxx

Description

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 2.8.0, fixed 2.8.3rc1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database