PYSEC-2026-12

At a glance

Published
Updated
CVE
CVE-2026-24098
Aliases
BIT-airflow-2026-24098, GHSA-5g2w-9f8g-g5q7
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Description

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue

Affected packages

PackageVersions
PyPI · apache-airflowintroduced 3.0.0, fixed 3.1.7

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database