PYSEC-2026-12
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2026-24098
- Alias
- BIT-airflow-2026-24098, GHSA-5g2w-9f8g-g5q7
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Description
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to. Users are advised to upgrade to 3.1.7 or later, which resolves this issue
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow | introduced 3.0.0, fixed 3.1.7 |
Références
- http://www.openwall.com/lists/oss-security/2026/02/09/3 ADVISORY
- https://lists.apache.org/thread/nx96435v77xdst7ls5lk57kqvqyj095x ADVISORY
- https://github.com/apache/airflow/pull/60801 FIX
- https://github.com/advisories/GHSA-5g2w-9f8g-g5q7 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |